CVE-2026-76801

FireBox <= 3.1.10 - Authenticated (Author+) Remote Code Execution to Privilege Escalation

State
Published
Severity
8.8 High
Published
Sep 9, 2026
Updated
Sep 9, 2026
Reserved
Aug 19, 2026

Read the record on cve.org

Description

The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.

Scores

CVSSScoreVectorSource
3.18.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HWordfence

Weaknesses

  • CWE-269 Improper Privilege Management

Affected Products

ProductVersions
FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonmentfireplugins
  • 3.1.10 and earlierAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.