CVE-2026-77405

RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser

State
Published
Severity
9.4 Critical
Published
Sep 16, 2026
Updated
Sep 18, 2026
Reserved
Aug 20, 2026

Read the record on cve.org

Description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.

Scores

CVSSScoreVectorSource
4.09.4 CriticalCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:NGitHub_M

Weaknesses

  • CWE-326 Inadequate Encryption Strength

Affected Products

ProductVersions
amqp091-gorabbitmq
  • < 1.13.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.