CVE-2026-85241
SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization
- State
- Published
- Severity
- 5.3 Medium
- Published
- Sep 3, 2026
- Updated
- Sep 4, 2026
- Reserved
- Sep 3, 2026
Description
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 5.3 Medium | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X | VulDB |
| 3.1 | 6.3 Medium | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C | VulDB |
| 3.0 | 6.3 Medium | CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C | VulDB |
| 2.0 | 6.5 Medium | AV:N/AC:L/Au:S/C:P/I:P/A:P/E:ND/RL:OF/RC:C | VulDB |
Weaknesses
Affected Products
| Product | Versions |
|---|---|
BloodHoundSpecterOps |
|
References
- VDB-398471 | SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorizationvdb-entrytechnical-description
- VDB-398471 | CTI Indicators (IOB, IOC, TTP, IOA)signaturepermissions-required
- CVE-2026-85241 | CVE Analysis and Reportthird-party-advisory
- Submit #894488 | SpecterOps BloodHound 9.4.0 Improper Authorizationthird-party-advisory
- https://github.com/SpecterOps/BloodHound/commit/39d1276a63e95a7713f954dea632a19651d9cebbpatch
- https://github.com/SpecterOps/BloodHound/releases/tag/v9.6.0-rc1patch
- https://github.com/SpecterOps/BloodHound/product
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.