CVE-2026-96883
Type confusion in AWS pgcollection allows remote code execution
- State
- Published
- Severity
- 8.7 High
- Published
- Sep 24, 2026
- Updated
- Sep 24, 2026
- Reserved
- Sep 23, 2026
Description
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions.
To remediate this issue, users should upgrade to version 2.1.2 or later.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 8.7 High | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | AMZN |
| 3.1 | 8.8 High | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | AMZN |
Weaknesses
- CWE-843 Access of resource using incompatible type ('type confusion')
Affected Products
| Product | Versions |
|---|---|
pgcollectionAWS |
|
References
- https://github.com/aws/pgcollection/releases/tag/v2.1.2release-notespatch
- https://aws.amazon.com/security/security-bulletins/2026-118-aws/vendor-advisory
- https://github.com/aws/pgcollection/security/advisories/GHSA-g539-cj32-hv6rthird-party-advisory
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.